Problem ERROR WoWpoPolsku-Quests

Dodatek odpowiedzialny za spolszczenie questów (misji)
darkodn80
Posty: 1
Frakcja: Przymierze
Rasa: Troll
Klasa: Mag

Problem ERROR WoWpoPolsku-Quests

Post autor: darkodn80 »

Witam mam problem z uruchomieniem WoWpoPolsku-Quests (baza questów z dnia 2022-12-19).

Co może być przyczyną. Info błędu poniżej.

Kod: Zaznacz cały

Message: ...ace/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1717: attempt to index field '?' (a nil value)
Time: Fri Dec 30 12:56:23 2022
Count: 1
Stack: ...ace/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1717: attempt to index field '?' (a nil value)
[string "@Interface/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua"]:1717: in function <...ace/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1710>
[string "=[C]"]: in function `EnumQuestWatchData'
[string "@Interface/AddOns/Blizzard_ObjectiveTracker/Blizzard_QuestObjectiveTracker.lua"]:281: in function `UpdatePOIs'
[string "@Interface/AddOns/Blizzard_ObjectiveTracker/Blizzard_ObjectiveTracker.lua"]:1578: in function `ObjectiveTracker_UpdatePOIs'
[string "@Interface/AddOns/Blizzard_ObjectiveTracker/Blizzard_ObjectiveTracker.lua"]:1452: in function <...zzard_ObjectiveTracker/Blizzard_ObjectiveTracker.lua:1365>
[string "=[C]"]: ?
[string "=[C]"]: in function `ObjectiveTracker_Update'
[string "@Interface/AddOns/Blizzard_ObjectiveTracker/Blizzard_ObjectiveTracker.lua"]:911: in function <...zzard_ObjectiveTracker/Blizzard_ObjectiveTracker.lua:876>

Locals: (for generator) = <function> defined =[C]:-1
(for state) = <table> {
 72192 = Frame {
 }
 72193 = Frame {
 }
 71026 = Frame {
 }
 72482 = Frame {
 }
 71210 = Frame {
 }
 66847 = Frame {
 }
 70883 = Frame {
 }
 72354 = Frame {
 }
 67606 = Frame {
 }
}
(for control) = 72192
questID = 72192
block = Frame {
 0 = <userdata>
 lines = <table> {
 }
 id = 72192
 currentLine = Frame {
 }
 height = 26.380949
 HeaderButton = ObjectiveTrackerBlocksFrameHeader {
 }
 blockTemplate = "ObjectiveTrackerBlockTemplate"
 HeaderText = FontString {
 }
 nextBlock = Frame {
 }
 used = true
 module = <table> {
 }
}
str_ID = "72192"
(*temporary) = <function> defined =[C]:-1
(*temporary) = FontString {
 0 = <userdata>
 colorStyle = <table> {
 }
}
(*temporary) = nil
(*temporary) = 1
(*temporary) = false
(*temporary) = FontString {
 0 = <userdata>
 minLineHeight = 12
 SetFormattedText = <function> defined @Interface/SharedXML/SecureUtil.lua:86
 baseLineHeight = 14
 ScaleTextToFit = <function> defined @Interface/SharedXML/SecureUtil.lua:96
 SetText = <function> defined @Interface/SharedXML/SecureUtil.lua:81
 SetMinLineHeight = <function> defined @Interface/SharedXML/SecureUtil.lua:91
}
(*temporary) = false
(*temporary) = <userdata>
(*temporary) = 1
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field '?' (a nil value)"
objectiveSpecials = <table> {
 Waypoint = <function> defined @Interface/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1700
 ClickComplete = <function> defined @Interface/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1657
 Failed = <function> defined @Interface/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1662
 QuestComplete = <function> defined @Interface/AddOns/WoWpoPolsku_Quests/WoWpoPolsku_Quests.lua:1666
}
Awatar użytkownika
WoWpoPolsku Team
Platine
Posty: 979

Re: Problem ERROR WoWpoPolsku-Quests

Post autor: Platine »

Dlaczego nie piszesz, w której wersji WoW'a (patch) masz ten problem?
Najlepiej skopiuj pierwszą linijkę z głównego pliku dodatku WoWpoPolsku-Quests.lua np.

-- Addon: WoWpoPolsku_Quests (wersja: 10.02) 2022.11.01
ODPOWIEDZ