Polskie znaki

Dodatek odpowiedzialny za spolszczenie wypowiedzi NPC (dymki)
Awatar użytkownika
Pastel_Chaos
Posty: 3
Frakcja: Przymierze
Rasa: Worgen
Klasa: Łotrzyk
BattleTag: Loudly303#2612

Polskie znaki

Post autor: Pastel_Chaos »

Hej, hej. Podczas moich przygód w Azeroth zauważyłem, że Npc przy spolszczonych wypowiedziach mają trudności w wypowiadaniu polskich znaków i zastępują je znakami zapytania. Czy jest jakiś sposób żeby to naprawić?
Awatar użytkownika
WoWpoPolsku Team
Erdzio
Posty: 279
Frakcja: Horda
Rasa: Worgen
BattleTag: Erdzio#2624

Re: Polskie znaki

Post autor: Erdzio »

Pierwsze zadane pytanie będzie dotyczyło aktualizacji, czyli na której wersji WoWa grasz i czy masz najnowszą wersję addonu.
Nie samymi questami worgen żyje, dymki też trzeba tłumaczyć. I Gossipy. No i książki... I Filmy, i Cinematici też...
Awatar użytkownika
WoWpoPolsku Team
Platine
Posty: 749

Re: Polskie znaki

Post autor: Platine »

Jest to problem z czcionkami polskimi. Albo się nie ładują, albo nasz zły plik z czcionkami.
Podaj w którym momencie to występuje (który addon to obsługuje) oraz jakie wersje dodatków używasz.
A najlepiej jakbyś jakieś zdjęcie załączył.
Awatar użytkownika
Pastel_Chaos
Posty: 3
Frakcja: Przymierze
Rasa: Worgen
Klasa: Łotrzyk
BattleTag: Loudly303#2612

Re: Polskie znaki

Post autor: Pastel_Chaos »

Gram sobie na retail'u czyli patch 8.3.0, natomiast jeśli chodzi o wersję addonów to aktualizuję je w miarę systematycznie przez aplikację twitcha. Z problemem spotykam się dosyć często zwłaszcza z addonem Bubbles, ale i (tak jak przed sekundą robiąc questy w Stormsong Valley) w tektach w Cinematicach (co zdarza się już rzadziej). Ciekawe jest to że w oknie czatu wszystko tłumaczy się dobrze i nie ma tam żadnych problemów.
Załączniki
Tutaj przykład
Tutaj przykład
WoWScrnShot_062820_134759.jpg (2.47 MiB) Przejrzano 4199 razy
Przechwytywanie.PNG
Przechwytywanie.PNG (55.92 KiB) Przejrzano 4199 razy
Awatar użytkownika
WoWpoPolsku Team
Borygo
Posty: 852
Lokalizacja: Świnoujście
Frakcja: Horda
Rasa: Tauren
Klasa: Paladyn

Re: Polskie znaki

Post autor: Borygo »

Wydaje mi się, że któryś z addonów od UI to powoduje.

Jak byś mógł najpierw, wszystkie addony wyłączyć i zobaczyć, czy dalej problem występuje, jeśli zniknie to w tedy pojedynczo uruchamiać kolejne dodatki i wtedy wyjdzie, który powoduje problem.

W tedy będziemy mogli coś wukompinować, oczywiście jeśli moje przypuszczenia są słuszne.

ps. a tak poza tym świetnie clern UI, czym to zrobiłeś?
Awatar użytkownika
WoWpoPolsku Team
Platine
Posty: 749

Re: Polskie znaki

Post autor: Platine »

Na zdjęciu mamy widok działania dodatku BUBBLES.
W folderze, gdzie są pliki dodatku jest kotalog "Fonts" i w nim plik z polskimi czcionkami:
"Interface\\AddOns\\WoWpoPolsku_Bubbles\\Fonts\\frizquadratatt_pl.ttf"
Jaką wielkość masz tego pliku?
Powinien mieć 57 784 bajtów.
Jeśli tyle ma, to OK, plik jest prawidłowy, tylko coś nie ładuje u ciebie tego pliku do dymku (linia 75 w pliku .lua).
Ale mam inne pytanie - czy jak wywołasz okno konfiguracji dodatku - masz polskie znaki?
/bbtr
Awatar użytkownika
WoWpoPolsku Team
Erdzio
Posty: 279
Frakcja: Horda
Rasa: Worgen
BattleTag: Erdzio#2624

Re: Polskie znaki

Post autor: Erdzio »

Jestem mało spostrzegawczy i nie gram za dużo w WoWa, ale mam wrażenie, jakby dymki jakoś inaczej wyglądały, to dorzucę; masz jakiś addon, który zmienia ich wyświetlanie? Może się gryzą jakoś dodatki.
Edit: faktycznie mało spostrzegawczy, bo Borygos o tym pisał xD
Nie samymi questami worgen żyje, dymki też trzeba tłumaczyć. I Gossipy. No i książki... I Filmy, i Cinematici też...
Awatar użytkownika
Pastel_Chaos
Posty: 3
Frakcja: Przymierze
Rasa: Worgen
Klasa: Łotrzyk
BattleTag: Loudly303#2612

Re: Polskie znaki

Post autor: Pastel_Chaos »

Borygo pisze: 28 cze 2020, 18:04 Wydaje mi się, że któryś z addonów od UI to powoduje.

Jak byś mógł najpierw, wszystkie addony wyłączyć i zobaczyć, czy dalej problem występuje, jeśli zniknie to w tedy pojedynczo uruchamiać kolejne dodatki i wtedy wyjdzie, który powoduje problem.

W tedy będziemy mogli coś wukompinować, oczywiście jeśli moje przypuszczenia są słuszne.

ps. a tak poza tym świetnie clern UI, czym to zrobiłeś?
UI budowałem sobie pod "immersję" tak, żeby łatwiej i przyjemniej można było zagłębiać się w lore gry. Składa się głównie z addonów Bartender4, DynamicCam i AzeriteUI i to ten ostatni powodował błąd. Usunąłem już plik odpowiedzialny za podmianę domyślnej chmurki i wszystko działa jak powinno. Dziękuję wszystkim za pomoc i poświęcony czas <3
ODPOWIEDZ